Degraded Performance – JPY Currency Processing
Resolved
Jul 3, 2026 at 12:01pm UTC
The issue affecting JPY currency rates has been resolved. Web checkout and CMS functionality for JPY transactions are now operating normally.
We have verified that services are functioning as expected and will continue to monitor the system to ensure ongoing stability.
We apologize for any inconvenience this may have caused and appreciate your patience.
Affected services
Created
Jul 3, 2026 at 11:45am UTC
We are currently investigating an issue affecting JPY currency rates. As a result, users transacting in JPY may experience issues with web checkout and CMS functionality.
Our team is actively working to identify the cause and restore normal service as quickly as possible. We will provide updates as more information becomes available.
Affected services