Back to overview
Downtime

Dashboard is unavailable

Jun 19, 2026 at 2:02pm UTC
Affected services
Dashboard
API

Resolved
Jun 19, 2026 at 2:10pm UTC

All systems have been operational since 14:10 UTC. We will publish a detailed incident report shortly.

We apologize for the inconvenience and disruption caused.

Updated
Jun 19, 2026 at 2:10pm UTC

Service appears to be returning to normal. We are continuing to monitor the situation closely and will provide further updates.

Created
Jun 19, 2026 at 2:02pm UTC

Dashboard is currently unavailable and our team is investigating the issue. We will keep you posted as we investigate.