Back to overview
Degraded

Background Job Processing Delays

Apr 25, 2026 at 8:00am UTC
Affected services
Dashboard

Resolved
Apr 25, 2026 at 6:33pm UTC

We have identified and fixed a root cause and now continue monitoring our systems.

A full root cause analysis (RCA) will be shared once available.

Thanks again for your patience.

Updated
Apr 25, 2026 at 12:43pm UTC

We are experiencing further issues and we are actively working on mitigation.

Updated
Apr 25, 2026 at 9:00am UTC

Background job processing has now fully recovered, and systems are operating normally.

We’re continuing to monitor the situation closely to ensure stability. A full root cause analysis (RCA) will be shared once available.

Thanks again for your patience.

Created
Apr 25, 2026 at 8:00am UTC

We’re currently experiencing delays in background job processing.

Our team has identified the root cause, and the backlog is actively decreasing as we work through it. We’re closely monitoring the situation and continuing to make progress toward full recovery.

Thanks for your patience — we’ll share another update soon.