Delay in transactional email delivery
Resolved
May 13 at 05:13pm BST
The issue with transactional email delays has been fully resolved. All previously queued emails have now been successfully delivered, and the system is operating normally.
Affected services
Dashboard
Updated
May 13 at 04:13pm BST
New transactional emails are now being delivered without delays.
However, some emails from earlier remain queued due to the previous issue. We are actively working to deliver all pending messages as quickly as possible.
Affected services
Dashboard
Created
May 13 at 02:03pm BST
We are currently experiencing degraded performance with Ventrata's email system. As a result, all transactional emails are being delivered with delays. Our team is investigating and working to restore normal delivery times as soon as possible.
Affected services
Dashboard