Back to overview
Degraded

Transactional Email Delivery Delays

Jun 4, 2026 at 10:42pm UTC
Affected services
Connections & External Services

Resolved
Jun 4, 2026 at 11:41pm UTC

Transactional email delivery is showing signs of recovery after the earlier degraded performance from our email provider. The provider has marked the incident as resolved, and we are seeing the backlog of queued messages continue to decrease.

Some emails may still be delayed while the remaining backlog is processed. We will continue to monitor delivery performance and provide further updates if needed.

Created
Jun 4, 2026 at 10:42pm UTC

Our email provider is currently experiencing degraded performance, resulting in delays to transactional email delivery. Emails are still being accepted and queued for processing, but delivery times may be longer than normal. We are actively monitoring the situation and will provide updates as they become available.