Back to overview
Degraded

Intercom (Support Platform) Degraded

Oct 20 at 05:00pm BST
Affected services
Dashboard

Resolved
Oct 21 at 05:11pm BST

Intercom has fully resolved and our support portal is working as expected.

Created
Oct 20 at 05:00pm BST

Ongoing AWS us-east-1 issues are still impacting Intercom, our support platform. As a result, support via Intercom is not working as expected.

In the meantime, please reach us at support@ventrata.com for assistance. We’ll update once Intercom is fully restored.