Back to overview
Degraded

US Adyen Terminals Failing Initialization

Sep 15 at 02:30pm BST
Affected services
API

Updated
Sep 15 at 04:23pm BST

The workaround did not work in all cases, and we continue to pursue both a full solution from Adyen and replacement workaround as quickly as possible. We’ll provide a further update in the next 30 minutes.

Updated
Sep 15 at 03:27pm BST

We have identified the problem and continue to work with Adyen on a resolution. In the mean time we are preparing a hotfix that will provide a potential workaround that should be ready in the next 30 minutes

Created
Sep 15 at 02:30pm BST

We are currently aware of an issue affecting Adyen terminals in the United States. Impacted devices are failing to complete the initialization process and are therefore unable to process transactions.

Our team has confirmed that this is isolated to US terminals. We are actively escalating the matter to Adyen for further investigation and resolution.

We will provide updates here as soon as more information becomes available.