Back to overview
Degraded

Checkout degradation

Apr 21 at 06:03pm BST
Affected services
API

Resolved
Apr 22 at 11:54am BST

Our partner Adyen has released a Root Cause Analysis on their webpage, which you can find at the following link: https://www.adyen.com/knowledge-hub/mitigating-a-ddos-april-2025

Updated
Apr 22 at 07:16am BST

Our partner Adyen communicated that their Checkout services performance has stabilised since 02:16 CEST. At this point, all payment processing capabilities have returned to normal.

https://status.adyen.com/

Updated
Apr 21 at 08:16pm BST

Adyen is again experiencing issues. We will be updating as soon as there is more information. In the meantime, follow https://status.adyen.com/

Updated
Apr 21 at 07:33pm BST

Adyen payment processing has now fully resolved and so has resolved our degradation.

https://status.adyen.com/

Updated
Apr 21 at 06:12pm BST

Our partner Adyen has acknowledged an issue and they are working to resolve it.

Follow their status page for more detailed updates: https://status.adyen.com/

Created
Apr 21 at 06:03pm BST

We’re investigating an issue with Adyen that is impacting some users. We’ll share another update shortly.