Back to overview
Degraded
API performance degraded
Jul 02 at 03:04pm BST
Affected services
API
Resolved
Jul 02 at 03:06pm BST
Incident resolved
Affected services
API
Created
Jul 02 at 03:04pm BST
A sudden increase of requests caused a higher API latencies and degraded performance for all users.
Prevention actions taken
Request concurrency limiting policies were updated and made stricter, allowing the system to distribute and handle requests fairly without degrading the overall performance.
Affected services
API